Author Topic: VEMS V3.3 Dead cpu after MCP3208-failure?  (Read 98 times)

Offline kgbengt

  • New Users
  • *
  • Posts: 1
  • BHP: 0
VEMS V3.3 Dead cpu after MCP3208-failure?
« on: March 03, 2020, 01:29:29 am »
Hello,
Any ideas what might have happened?

After changing my failing MCP3208-chip to get the analogue inputs working i no longer get readings from TPS, MAT, IAT or MAP-sensors. Also, the voltage reading is about 25V. Before the repair it worked as it should.
The analogue inputs seem to work, and EGT shows reasonable values.
I also get rpm-signal and fuel pump and cooling fan works.
Firmware 1.2.43, i tried 1.2.38 with same result.

The car is a MB300E with M103-engine, HolsetHX40 on a Turbobandit exhaust manifold.

Offline gunni

  • Hero Member
  • *****
  • Posts: 1481
  • BHP: 37
Re: VEMS V3.3 Dead cpu after MCP3208-failure?
« Reply #1 on: March 03, 2020, 01:12:36 pm »
The voltage reading being so far off suggests that the voltage divider for battery voltage is no longer working. You´d have to try and read the board schematics and trace things back, or just send it to VEMS for a repair?