VEMS Community Forum

Technical => Ignition => Topic started by: rossi46numberone on June 04, 2011, 10:19:33 pm

Title: Dead coil = dead igbt ???
Post by: rossi46numberone on June 04, 2011, 10:19:33 pm
Hi,
From a few days got some missfire and back fire,it appear that the first cyl coil die and now the engine run like a nightmare :'(
Does the igbt output burn ???
Michele.
Title: Re: Dead coil = dead igbt ???
Post by: Erikk on June 04, 2011, 10:32:58 pm
Well, try another IGBT and see if its still dead?
Title: Re: Dead coil = dead igbt ???
Post by: rossi46numberone on June 05, 2011, 01:05:28 am
In fact my Vems was ordered with 8 igbt's,My first config used the first "pair"of 2 output because of the wasted spark config and when this missfire began I swaped to the other pair and after +/- 200km the first cyl output of the other pair dies too.
My question is :
If it is only the coil of cyl 1,I suppose only his respective igbt should die?or does it have any inlfuence on the other ignition output
If yes I will be able to replace it easily....


Michele
Title: Re: Dead coil = dead igbt ???
Post by: boostd audi on June 05, 2011, 09:12:44 am
changing them is not difficult either so its not too bad..
Title: Re: Dead coil = dead igbt ???
Post by: mattias on June 06, 2011, 03:28:52 am
What fuses are used to provide voltage to the coils? How are they connected to them? One fuse for all?
Most regular systems can use 10A,  should not blow in most systems. With 15A, anything goes but you run a greater risk of a bad coil (short-circuit) killing an IGBT.
Title: Re: Dead coil = dead igbt ???
Post by: rossi46numberone on June 06, 2011, 07:15:35 pm
I think there is no fuse at all :-\.Ihave to check the original harness wiring....
Do you think it would be greater to provide each coil one by one?
In this case what would be the best fuse value?
Title: Re: Dead coil = dead igbt ???
Post by: boostd audi on June 06, 2011, 07:34:30 pm
 i am wasted spark and i only use two igbt to run my car.. but i have 1 10a fuse on the power wire for the bosch 2x2.
Title: Re: Dead coil = dead igbt ???
Post by: utkuselamoglu on June 28, 2011, 07:26:23 pm
I have also burned one IGBT than switch to logic level without any issues. But still not sure that how the only one output had burned suddenly.