Author Topic: Dwell Time Falls With RPM  (Read 4696 times)

Offline Kenny Watson

  • Jr. Member
  • **
  • Posts: 44
  • BHP: 3
Dwell Time Falls With RPM
« on: June 16, 2011, 01:22:09 am »
When I pass exactly 4100rpm, my dwell time drops off proportionally to rpm.

Dwell is the pink line. Yellow rpm, blue is MAP. I use "1" for map scale.

It's like it's limiting the coils' duty cycle. This a 6 cylinder running wasted spark.

Any thoughts? Does it with both 1.1.81 and 1.192


Offline mattias

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1075
  • BHP: 41
    • Sävar Turbo Site
Re: Dwell Time Falls With RPM
« Reply #1 on: June 16, 2011, 01:41:06 am »
Post .vemslog instead, and I don't mean a hard to read screenshot of it.

Offline Kenny Watson

  • Jr. Member
  • **
  • Posts: 44
  • BHP: 3
Re: Dwell Time Falls With RPM
« Reply #2 on: June 16, 2011, 01:53:11 am »

Offline mattias

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1075
  • BHP: 41
    • Sävar Turbo Site
Re: Dwell Time Falls With RPM
« Reply #3 on: June 16, 2011, 02:28:38 am »
Worked like a charm!

What if you run a more probable 3.0-3.5 ms dwell and use MAP scale = 5  ?

This is interesting for the developers, unless I missed a setting but I think did not.
It should not lower the dwell at all, at 6000 rpm there is 10 ms per crank rotation so plenty of time left.


On another note : Why run so silly rich? You're fouling your oil and washing your cylinder walls.
VE does not DOUBLE from 4000 rpm to 6000 rpm. It usually becomes less. Pressure is compensated for in the algorithm.
Just copy the 130 kPa line to all lines above it and start from there, and lower the boost to as low as you can and get it sorted there first.

Your lambda sensor goes flatline when boost comes on and I'm not sure it's even trustworthy after it returns. If it makes sense at 6000+ rpm then the higher VE is actually compensating for a low fuel pressure problem,  in that case you need stronger/more fuel pump(s).

Suggestion as you seem to trust EGO correction at full throttle (most don't). Enable -15% EGO correction (+/- 5% now) and it should tell you how far off you are in your datalogs. Abort as soon as the correction hits 85% (max enleanment), you're way off by then and should re-tune the VE table a lot. Smooth the rest of the surrounding cells, they won't change more than single digit %.
« Last Edit: June 16, 2011, 02:31:38 am by mattias »

Offline Kenny Watson

  • Jr. Member
  • **
  • Posts: 44
  • BHP: 3
Re: Dwell Time Falls With RPM
« Reply #4 on: June 16, 2011, 03:41:19 am »
Thanks for the insight. I do think i will reduce base dwell and use map scale, at least as a temporary measure, but it still bothers me that it seems something is not working right (more thhoughts on this below). It is an EDIS coil so they do like lots of dwell. I am shocked it was not misfiring with 2.5ms of dwell and 20+psi of boost.

This was a dyno pull. 2.8L volvo engine at 541whp.  ;D


It acts like there is a fuel delivery problem, yeah. This is why it had crazy high VE values at high rpm yet is still lean, more and more duty cycle has no real effect. Actually, I suspect there is no fuel delivery problem, but a VEMS problem. It acts exactly like fuel pressure is falling off, I agree, but it isn't. Verified on the dyno.

I am actually wondering if the very low dwell was creating poor combustion/some slight high speed misfire that is tricking the lamdba sensor into reading leaner than things actually are. Know what I mean? Or alternatively, if the dwell is changing unintentionally, what is else is? The pulsewidth does report what I command it though.

Here is the dyno graph just for interest's sake. Cheers!




The extremely rich spot in lower RPM is because I was still getting the methanol injection set up correctly on the dyno, and also because I was tuning increasing boost by 20kpa at a time, and interpolating values (like you mentioned). However because of this weird fuel delivery issue (possibly connected to the spark issue) it would way overshoot on low rpm fueling and/or way undershoot on high rpm fueling .

I get the feeling something is fundamentally wrong with the engine control at high rpms.
« Last Edit: June 16, 2011, 03:45:43 am by Kenny Watson »