Author Topic: tool ignition lock  (Read 6921 times)

Offline Wayne

  • Jr. Member
  • **
  • Posts: 60
  • BHP: 3
tool ignition lock
« on: August 08, 2011, 12:30:18 pm »
Hello,

i have some problems with the tool ignition lock.
FW1.1.74
the ignition lock is allways set to 10% after power up the ecu.
When i set value to zero, then it's off, but when you power up the ecu
the lock is always on 10 degrees.

Second problem is "spark cut based idle".
when i turn on the function, and i am under the defined throttle value,
there is 100% spark cut an the engine is off. ????


What is the problem ???

Offline mattias

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1075
  • BHP: 41
    • Sävar Turbo Site
Re: tool ignition lock
« Reply #1 on: August 08, 2011, 03:25:50 pm »
Post your vemscfg.

This could be down to simple settings, try 'F1 for help' in all dialogs and get some of your questions answered.

It's also possible that your ECU is old enough to not have a proper serial number in the CPU flash memory. That means more recent firmwares will lock the ignition advance to prevent pirate boards, in that case you need to get the board updated.

Offline Wayne

  • Jr. Member
  • **
  • Posts: 60
  • BHP: 3
Re: tool ignition lock
« Reply #2 on: August 08, 2011, 03:50:57 pm »
Hey, thats it !

The ECU was damaged, because the 18V transzorb diode was not assembled at the supply voltage.
I replaced the AtMega 128 and was not able to install a bootloader. So i program only the .hex
file of the actual FW.

Is this the reason too, that the spark cut idle is not working ?

What can i do to get this ECU runs correct ?

Offline mattias

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1075
  • BHP: 41
    • Sävar Turbo Site
Re: tool ignition lock
« Reply #3 on: August 08, 2011, 04:42:01 pm »
Contact info at vems.hu and see if you can get help with a new bootloader, either by programming it yourself with the proper tools or by sending the ECU to them.

Offline Wayne

  • Jr. Member
  • **
  • Posts: 60
  • BHP: 3
Re: tool ignition lock
« Reply #4 on: August 09, 2011, 10:39:03 am »
Hello,

i sent an e-mail to info...., and answered for a bootloader file.

I replace the ECU and changed to FW1.1.88. Car is running now.

But the "spark cut idle control" doesn't work.
When i activate, the engine goes off (100% spark cut) under the idle threshold value.(25%)

Anyone out there, who has experience with this function ??

I need them for ALS without throttle kicker.

reguards
Thomas

Offline gox

  • Full Member
  • ***
  • Posts: 196
  • BHP: 6
Re: tool ignition lock
« Reply #5 on: August 14, 2011, 06:40:49 pm »
I had the same problem with that function....
Maybe spark cut based idle control requires wasted spark....?
E30 2.7 - VEMS,KKK K27.2,Schrick,1bar

Offline rob@vems.co.uk

  • Hero Member
  • *****
  • Posts: 3115
  • BHP: 49
    • VEMS Forum
Re: tool ignition lock
« Reply #6 on: August 15, 2011, 01:50:01 pm »
The ECU won't know if its running wasted spark or not so I doubt its that.
In all cases of "missing functionality" I'd upgrade to the latest stable firmware and crack on with that...

Offline GintsK

  • Hero Member
  • *****
  • Posts: 1250
  • BHP: 49
Re: tool ignition lock
« Reply #7 on: August 15, 2011, 03:07:13 pm »
Spark cut ignition is dangerous for your exhaust!
If configured alone during overrun situation it collect mixture in exhaust and, when idle rpms finally reached, just ignite this bomb!

For what purpose you want activate that?

Offline gox

  • Full Member
  • ***
  • Posts: 196
  • BHP: 6
Re: tool ignition lock
« Reply #8 on: August 16, 2011, 02:39:53 am »
I had it on back on 1.0.73 after i got IGBT dead,i needed to run single coil.I had a problems so i turned that way of controlling idle off.
After some while i tryed to turn it on again whit engine running and it suddenly dies and PW goes to 0,if i try to start the engine with spark cut based idle control enabled it is just cranking with PW's 0...when spark cut idle control option is off engine stays alive and starts normally,so i gave up from that function,didnt tried it with 1.1.88 tough
E30 2.7 - VEMS,KKK K27.2,Schrick,1bar

Offline Wayne

  • Jr. Member
  • **
  • Posts: 60
  • BHP: 3
Re: tool ignition lock
« Reply #9 on: August 17, 2011, 12:35:41 pm »
I need the function for ALS without Throttle kicker.
But when i turn on this function and the throttle is under idle threshold, the ignition cut is 100% till engine goes off.

I tried the function in 1.1.88 and 1.1.74

There are not very much tables to fill in for this function, so i am shure there is no fault.
I drive wasted spark.

Offline GintsK

  • Hero Member
  • *****
  • Posts: 1250
  • BHP: 49
Re: tool ignition lock
« Reply #10 on: August 18, 2011, 10:17:40 am »
Generally for pre-opened throttle driveability purposes we have partial fuel cut mode. Try it!

Offline Wayne

  • Jr. Member
  • **
  • Posts: 60
  • BHP: 3
Re: tool ignition lock
« Reply #11 on: August 18, 2011, 12:07:47 pm »
Thanks for your info,
i will try it.

but,
partial fuelcut min power (in%) and
partial fuelcut max power (in%)

what does it mean ??

are these values throttle position (in%) or what?