Author Topic: Dead coil = dead igbt ???  (Read 4832 times)

Offline rossi46numberone

  • Full Member
  • ***
  • Posts: 125
  • BHP: 4
Dead coil = dead igbt ???
« on: June 04, 2011, 10:19:33 pm »
Hi,
From a few days got some missfire and back fire,it appear that the first cyl coil die and now the engine run like a nightmare :'(
Does the igbt output burn ???
Michele.

Offline Erikk

  • Jr. Member
  • **
  • Posts: 95
  • BHP: 7
Re: Dead coil = dead igbt ???
« Reply #1 on: June 04, 2011, 10:32:58 pm »
Well, try another IGBT and see if its still dead?
Sweden - erik.englund@gmail.com

Offline rossi46numberone

  • Full Member
  • ***
  • Posts: 125
  • BHP: 4
Re: Dead coil = dead igbt ???
« Reply #2 on: June 05, 2011, 01:05:28 am »
In fact my Vems was ordered with 8 igbt's,My first config used the first "pair"of 2 output because of the wasted spark config and when this missfire began I swaped to the other pair and after +/- 200km the first cyl output of the other pair dies too.
My question is :
If it is only the coil of cyl 1,I suppose only his respective igbt should die?or does it have any inlfuence on the other ignition output
If yes I will be able to replace it easily....


Michele

Offline boostd audi

  • Full Member
  • ***
  • Posts: 207
  • BHP: 9
    • vems.live
Re: Dead coil = dead igbt ???
« Reply #3 on: June 05, 2011, 09:12:44 am »
changing them is not difficult either so its not too bad..
boost addict's Vems powered Audi VRT s2

Offline mattias

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1075
  • BHP: 41
    • Sävar Turbo Site
Re: Dead coil = dead igbt ???
« Reply #4 on: June 06, 2011, 03:28:52 am »
What fuses are used to provide voltage to the coils? How are they connected to them? One fuse for all?
Most regular systems can use 10A,  should not blow in most systems. With 15A, anything goes but you run a greater risk of a bad coil (short-circuit) killing an IGBT.

Offline rossi46numberone

  • Full Member
  • ***
  • Posts: 125
  • BHP: 4
Re: Dead coil = dead igbt ???
« Reply #5 on: June 06, 2011, 07:15:35 pm »
I think there is no fuse at all :-\.Ihave to check the original harness wiring....
Do you think it would be greater to provide each coil one by one?
In this case what would be the best fuse value?

Offline boostd audi

  • Full Member
  • ***
  • Posts: 207
  • BHP: 9
    • vems.live
Re: Dead coil = dead igbt ???
« Reply #6 on: June 06, 2011, 07:34:30 pm »
 i am wasted spark and i only use two igbt to run my car.. but i have 1 10a fuse on the power wire for the bosch 2x2.
boost addict's Vems powered Audi VRT s2

Offline utkuselamoglu

  • Jr. Member
  • **
  • Posts: 22
  • BHP: 0
Re: Dead coil = dead igbt ???
« Reply #7 on: June 28, 2011, 07:26:23 pm »
I have also burned one IGBT than switch to logic level without any issues. But still not sure that how the only one output had burned suddenly.
utku selamoglu